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USE IN LIFE SUPPORT DEVICES OR SYSTEMS MUST BE EXPRESSLY AUTHORIZED.

STMicroelectronics PRODUCTS ARE NOT AUTHORIZED FOR USE AS CRITICAL COMPONENTS IN
LIFE SUPPORT DEVICES OR SYSTEMS WITHOUT THE EXPRESS WRITTEN APPROVAL OF
STMicroelectronics. As used herein:

1. Life support devices or systems are those
which (a) are intended for surgical implant into
the body, or (b) support or sustain life, and whose
failure to perform, when properly used in
accordance with instructions for use provided
with the product, can be reasonably expected to
result in significant injury to the user.

2. A critical component is any component of a life
support device or system whose failure to
perform can reasonably be expected to cause the
failure of the life support device or system, or to
affect its safety or effectiveness. 

INSTRUCTIONS FOR USE—WARNING

This product is an FCC Class-A apparatus. In a residential environment, it may cause
radioelectrical disturbances.

In addition, this programming board is not contained in an outer casing; consequently, it cannot be
immune against electrostatic discharges (ESD). It should therefore be handled only in static safe
working areas. Please refer to Appendix A: User and Work Environment Precautions on page 17 for
relevant safety information.
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1 INTRODUCTION

1.1 Overview

The ST9 EPB is a programming board kit which allows you to program ST9
microcontrollers having EPROM, OTP, OSD, EEPROM and FLASH memories.

The layout of the programming board included in your ST9 EPB kit varies
depending on the type and package of the ST9 microcontroller you wish to
program (a typical example is shown in Figure 1). However, the general
programming procedure explained in this book remains the same for all boards.

A complete listing of the ST9 family of programming boards, with a summary of the
devices they support is given in Appendix B: Current ST9 EPBs on page 19.

Note: The ST9 EPB is meant to program small numbers of microcontrollers (i.e. prototypes in the
development stage). For mass production programming, it is recommended that you use the
appropriate gang programmer.

The programming board is linked via the parallel port, to a host PC running the ST9
Visual Programmer software (STVP9). This software interface allows you to
customize and control the programming. The object code in either the Intel® HEX
and Motorola® S19 format can be read and used to program the target devices.

Figure 1: Typical ST9 EPB programming board
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STVP9 also offers VERIFY, BLANK CHECK, READ, ERASE and other utility
functions.

1.2 Hardware features

A range of programming boards allow you to program all of the EPROM, OTP,
OSD, EEPROM and FLASH versions of the ST9 family. In Situ Programming (ISP)
is also available for the FLASH devices.

1.3 Software features

A host PC running the STVP9 is the control interface for the ST9 EPB.

STVP9 is a graphical Windows interface that lets you:

• Read, view, edit and save executable files in the Intel® HEX and Motorola® S19
formats, generated by the Assembler, Linker or C Compiler for ST
microcontrollers.

• Program executable files into ST microcontrollers.

• View and verify a microcontroller's memory contents.

• Either create a project that defines how to program the microcontroller(s) or
load the files whose contents you want to program and then execute the
program.

STVP9 includes a detailed online help utility.
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2 GETTING STARTED

2.1 Delivery Checklist

Check that your ST9 EPB programming board kit contains the following items:

• 1 ST9 EPB Eprom Programming Board (i.e. the EPB appropriate to the sales
type ordered).

• 1 power supply.

• 1 parallel cable.

• 1 MCU on CD CDROM containing the STVP9 software.

• 1 14-pin HE10 type ribbon cable for ISP mode (if provided on the programming
board for the sales type ordered).

2.2 Setting up the EPB

To set up the ST9 EPB hardware, follow these instructions:

1 Shut down and power-off the host PC.

2 Connect one end of the supplied parallel cable to connector P1 of the ST9 EPB
and the other end to one of the host PC’s parallel ports (LPT1 or LPT2).

Note: Be sure to use the parallel cable provided with your kit—using a longer parallel cable may
cause malfunctions. 
Connect the cable directly between the host PC and the programming board—the insertion of
additional cables or switch boxes between the host PC and the programming board may
cause malfunctions.
If a dongle (a hardware key required by some software packages) is already connected to the
PC’s parallel port, it should not interfere with the programming board. However, if a
malfunction of the board should occur, please remove the dongle and restart the above
sequence.

3 Power on the programming board by connecting the power supply to the
programming board and to the mains. Ensure that the power supply is adapted
to the mains voltage and outlet type used in your country.

Note: The board can be supplied from the integrated power supply provided with the board, or from
an external +15 VDC / 0.5 A power supply.

4 Power on the host PC and install the software provided as described in the next
section.
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2.3 Installing the STVP9 software

Your ST9 EPB comes with the MCU on CD CD-ROM which contains STVP9 and a
number of other ST9 software tools. These tools are compatible with Windows®

95, 98, 2000 and Windows® NT® operating systems.

Note: Windows® 2000 and NT® users must have administrator privileges to install STVP9.

To install STVP9 , follow these steps:

1 Close all other open applications on your Windows desktop.

2 Insert the MCU on CD into your CD-ROM drive. The CD-ROM’s autorun feature
will open up a welcome screen on your PC. If the autorun feature does not work,

use Windows® Explorer to browse to the CD-ROM’ s root folder, and double-
click on Welcome.exe.

3 Select Install Your Development Tools from the list of options. A new screen
will appear listing the different families of STMicroelectronics MCUs.

4 Use your mouse to place the cursor over the ST9 Tools option. Choose ST
Tools and then ST Visual Programmer for ST9-EPB (STVP9) from the list
that appears.

5 The install wizard will be launched. Follow the instructions that appear on the
screen.

The installation is now complete. How to start programming with STVP9 is
described in Chapter 3:  How to Program on page 9.
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3 HOW TO PROGRAM

3.1 Programming methods

Your ST9 EPB programming board is provided with at least one Zero Insertion
Force (ZIF) socket which allows the programming of packaged MCUs. In addition
to classic MCU programming using ZIF sockets, those MCUs with FLASH
memories can be programmed using the In Situ Programming (ISP) mode. ISP
mode allows the ST9 program memory contents to be updated using a standard
ST9 programming tool after the device is mounted on the application board. ISP
programming is described in Chapter 4 on page 15.

Here we describe how to connect your device for programming using these
methods.

3.1.1 Installing a device for programming with the ZIF sockets

This section gives general guidelines on how to insert a device you wish to
program into the ZIF sockets on the programming board.

The online help for the STVP9 includes programming board layouts for all of the
ST9 EPBs. 

1 Set up the EPB as described in Section 2.2 on page 7.

2 Make sure that your EPB is powered off.

3 From your host PC select Start>Programs>STVP for ST9 EPB to launch the
STVP9 software program. From the main menu bar, select Help>Hardware. 

4 A list of ST9 EPBs will appear in the online Help window. Scroll down until you
find your programming board model, and click on it.

5 Using the board layout that appears for your programming board, identify the
ZIF socket for your device package on the programming board.

6 Place the device into the designated socket with pin 1 matching the mark on the
board.

Caution: Take care when placing the device into a socket so as not to damage the device or the board.
Forcing the MCU into the socket may result in damage to the socket. 
Devices are powered only during read or write operations—a red LED (labelled LD1 or MCU
Power) will light when the device is powered. Never insert or remove devices when the
EPB’s red LED is ON . 
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Note: Some ZIF sockets have levers or covers that you must lift in order to place the device, and
then re-fit after the device is in place.

7 Power on the EPB.

3.2 A typical programming session

The following instructions describe how you would typically program an ST
microcontroller using STVP9.  Note that this is not the only way to program an ST
microcontroller using STVP9; for more information on how to use the STVP9, click
the Help command in the main menu bar.

1 Make sure that the microcontroller you want to program is correctly connected
for programming, either via the ZIF socket or in ISP mode (see Chapter 4:  In
Situ Programming mode on page 15).

Figure 2: ZIF socket with lever

ZIF Socket

Place your device here, making sure to

1

align pin 1 on the device with the arrow
on the programming board

lever
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2 In the STVP9 window, from the main menu, select Configure>Configure ST
Visual Programmer. The ST Visual Programmer Configuration window is
displayed as shown below:

3 In the Select Hardware and Port tab of the window, choose the programming
device you are using from the list and the host PC parallel port to which it is
connected (i.e. LPT1 or LPT2).

Note: The list of supported devices shown in the screen capture above is not necessarily
complete—this list grows with each new version release of STVP9.

4 Click on the Select Device tab of the ST Visual Programmer Configuration
window.
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The list box shown below appears.

5 From the list shown in the Select Device tab of the ST Visual Programmer
Configuration window, select the device to be programmed.

6 Click Apply to save your changes without closing the dialog box, or OK to save
your changes and close the dialog box.

Note: You can also select a microcontroller type from the drop-down list in the toolbar.

7 In STVP9’s main window there are a number of tabs with one or more of the
following names (depending on the device selected): FLASH, OSD, EPROM,
EEPROM, Option Bytes or Device Information.

8 Select one of the memory type tabs (i.e. FLASH, OSD, EPROM, EEPROM or
Option Bytes).

9 From the main menu, select File>Open and type the name of, or browse to, the
file you want to load.

10 In the list of files, click the file holding the code you want to program.

11 Click OK. When the file is loaded, the Information window (the black-
background text window at the bottom of the STVP9 application window)
displays file checksum and global device checksum. Global device checksum
represents checksum calculated without reserved area.

Select your 
target device 
with the ISP 
option if you 
wish to 
program your 
target device 
using In Situ 
Programming 
(ISP)
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12 To program the other device memory areas, repeat steps 8 to 11 above, each
time selecting a tab associated with a different memory area (i.e. ELASH, OSD,
EPROM, EEPROM or Option Bytes) that you wish to program.

Note: To open a file you’ve used recently, click its name at the bottom of the File menu.

13 FOR EPROM and FLASH ONLY: From the main menu, select Verify>Blank
Check to check that the ST microcontroller memory has not already been
programmed. (You cannot perform a blank check on EEPROM memory).

The results of the check are displayed in the information area.

14 From the main menu, select Program>All to program and verify all tabs.

15 From the main menu, select Verify>All to check that the programing session
was successfully completed (that the file contents match those programmed
into the microcontroller memory).
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4 IN SITU PROGRAMMING MODE

Microcontrollers with FLASH memories can be programmed using the In Situ
Programming (ISP) mode (also referred to as in-system programming). ISP mode
allows the contents of the ST9 program memory to be updated using a standard
ST9 programming tool after the device is mounted on the application board.

Those ST9 EPBs equipped with an ISP connector can be used as an external tool
that provides an interface between the host PC running STVP9 and the MCU
mounted in the application.

MCUs supporting ISP mode communicate with the application through a SCI
protocol in synchronous mode. The MCU also controls the application reset. The
application-mounted MCU starts out of reset mode by initializing its SCI to
communicate with the EPB. If the EPB doesn’t answer, the application will
automatically encounter the user’s code (or a HALT instruction if no user code is
available).

STVP9’s In Situ Programming software enables the PC to load executable code
(fppsci.hex code) into the FLASH memory of a Driver MCU mounted in on of the
ZIF sockets on the EPB. This Driver MCU is usually the same type of MCU that you
wish to program in situ. The code loaded into the Driver MCU located on the EPB
allows it to act as an interface between the PC and the MCU located on the
application.

EEPROM

Driver MCU FLASH component

Eprom Programming
Board

FLASH
FLASH

fppsci.hex

RIBBON CABLE
Port 6

Port 5
SCI W1

connector Reset
pin

connector

Port 5
SCI

Port 5
Reset

Target MCU

Application
Board

pa
ra

lle
l p

o
rt

The driver con-
trols the applica-
tion RESETn pin

Host PC 
running STVP9
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4.1 Setting up the EPB for ISP mode

1 Set up the EPB and host PC as described in Chapter 2:  Getting Started on
page 7.

2 Power on the EPB and the host PC.

3 Place the Driver MCU in the ZIF socket on the EPB which is appropriate for its
package. 

Note: Any spare MCU of the same type that you wish to program on the application board may be
programmed as a driver. For example, if you wish to program a ST92F120 device in situ, you
would use a spare ST92F120 MCU mounted in a ZIF socket of the ST92F120-EPB as the
Driver MCU.

4 Connect the ribbon cable between the 14-pin ISP connector on the EPB and the
ISP connector on your application board.

5 Switch on the application board.

6 Follow the instructions in Section 3.2: A typical programming session on
page 10, taking care to choose a device with an -ISP suffix from the Select
Device tab of the ST Visual Programmer Configuration window. STVP9 will
check the contents of the driver device installed on the EPB and update it if
necessary.

7 Load the file you want to program and program the device’s FLASH and
EEPROM memories.
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APPENDIX A: USER AND WORK ENVIRONMENT PRECAUTIONS

The following precautions are recommended when using the programming board:

• Any tester, equipment, or tool used at any production step or for any
manipulation of semi-conductor devices should have its shield connected to
ground.

• Your programming board should be placed on a conductive table top, made of
steel or clean aluminum or covered by an antistatic surface (superficial

resistivity equal to or higher than 0.5 MΩ/cm2), grounded through a ground
cable (conductive cable from protected equipment to ground isolated through a
1 MΩ resistor placed in series). 
All manipulation of finished goods should be made at such a grounded
worktable.

• The worktable should be free of all non-antistatic plastic objects.

• An antistatic floor covering grounded through a conductive ground cable (with
serial resistor between 0.9 and 1.5 MΩ) should be used.

• It is recommended that you wear an antistatic wrist or ankle strap, connected to
the antistatic floor covering or to the grounded equipment. 

• If no antistatic wrist or ankle strap is worn, before each manipulation of the
powered-on programming board, you should touch the surface of the grounded
worktable.

• It is recommended that antistatic gloves or finger coats be worn.

• It is recommended that nylon clothing be avoided while performing any
manipulation of parts.
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APPENDIX B:CURRENT ST9 EPBS

Salestype Package
Supported 

Devices
Memory Types / 

Programming Options

ST90E158-EPB2

PQFP80 ST90158
ST90158LV

OTP, EPROM

TQFP80 ST90158
ST90158LV

QFP80 ST90158
ST90158LV

LCC84 ST90158
ST90158LV

ST92E175-EPBJ

SDIP56 ST92175

OTP, EPROMQFP64 ST92175

TQFP64 ST92175

ST92E195-EPB

SDIP56 ST92195

OTP, EPROM, OSDQFP64 ST92195

TQFP64 ST92195

ST92E196 -EPB

SDIP56 ST92196

OTP, EPROM, OSDQFP64 ST92196

TQFP64 ST92196

ST92E141-EPB
SO34 ST92141

OTP, EPROM
SDIP32 ST92141

ST92E163-EPB

SDIP56  ST92163

OTP, EPROMQFP64 ST92163

TQFP64 ST92163

ST92F120-EPB

PQFP100 ST92F120
ST92T120

OTP, EPROM, FLASH, 
EEPROM
ISP mode supported for 
FLASH memory versionsCQFP100 ST92E120
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ST92F150-EPB

TQFP100 ST92F150x1
ST92F150x9
ST92F124x1
ST92F124x9

FLASH, EEPROM
ISP mode supported

PQFP100 ST92F150x1
ST92F150x9
ST92F124x1
ST92F124x9

TQFP64 ST92F150x1
ST92F150x9
ST92F124x1
ST92F124x9

Salestype Package
Supported 

Devices
Memory Types / 

Programming Options
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PRODUCT SUPPORT

If you experience any problems with this product or if you need spare parts or
repair, contact the distributor or ST sales office where you purchased the product.

Getting prepared before you call

Collect the following information about the product before contacting ST or your
distributor:

1 Name of the company where you purchased the programmer kit.

2 Date of purchase.

3 Order Code: Refer to the side of your programmer kit box. The order code will
depend on the region for which it was ordered (i.e. the UK, Continental Europe
or the USA).

4 Serial Number: The serial number is located on a label on the programming
board.

5 Target Device: The sales type of the ST9 microcontroller you are using in your
development.

Contact list

Note: For American and Canadian customers seeking technical support the US/Canada is split
in 3 territories. According to your area, contact the following sales office and ask to be
transferred to an 8-bit microcontroller Field Applications Engineer (FAE).

Canada and East Coast

STMicroelectronics
Lexington Corporate Center
10 Maguire Road, Building 1, 3rd floor
Lexington, MA 02421
Phone: 781-402-2650

Mid West

STMicroelectronics
1300 East Woodfield Road, Suite 410
Schaumburg, IL 60173
Phone: 847-517-1890
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West coast

STMicroelectronics, Inc.
30101 Agoura Court
Suite 118
Agoura Hills, CA 91301
Phone: 818-865-6850

Europe

France (33-1) 47407575
Germany (49-89) 460060
U.K. (44-1628) 890800

Asia/Pacific Region

Japan (81-3) 3280-4120
Hong-Kong (852) 2861 5700
Sydney (61-2) 9580 3811
Taipei (886-2) 2378-8088

Software updates

You can get software updates from the ST Internet web site http://mcu.st.com.
For information on firmware and hardware revisions, call your distributor or ST
using the contact list given above.
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